CVE-2026-22252: LibreChat MCP stdio Command Execution
CVE-2026-22252 is a critical flaw (CVSS 9.1) in LibreChat before v0.8.2-rc2 that lets any logged in user run shell commands as root. Upgrade now.
Deep dives, practical guides, and incident analyses from engineers who build Safeguard. No fluff, no vendor FUD — just what you need to ship secure software.
CVE-2026-22252 is a critical flaw (CVSS 9.1) in LibreChat before v0.8.2-rc2 that lets any logged in user run shell commands as root. Upgrade now.
CVE-2026-2225 is a remote SQL injection in the admin login of itsourcecode News Portal Project 1.0 (CVSS 7.3). No fix is listed, so restrict access.
CVE-2026-22249 is a high severity Zip Slip arbitrary file write (CVSS 7.1) in Docmost 0.21.0 to before 0.24.0. Upgrade to Docmost 0.24.0 or later.
CVE-2026-22247 is a medium SSRF in the GLPI webhook feature (CVSS 4.1) affecting 11.0.0 to 11.0.4. Upgrade to GLPI 11.0.5, which fixes the flaw.
CVE-2026-22238 is a critical missing authentication flaw (CVSS 9.8) in BLUVOYIX admin APIs that allows creating admin users. Contact the vendor.
CVE-2026-22237 is a critical information exposure (CVSS 9.8) of internal API documentation in BLUVOYIX. No fix is listed, so contact the vendor.
CVE-2026-22236 is a critical improper authentication flaw (CVSS 9.8) in BLUVOYIX backend APIs. No fixed version is listed, so contact the vendor.
CVE-2026-2223 is a remote SQL injection in the student pretest page of code-projects Online Reviewer System 1.0 (CVSS 7.3). No fix is listed.
CVE-2026-22214 is a critical stack buffer overflow (CVSS 9.8) in the RIOT OS ethos utility, up to 2026.01-devel-317. Update RIOT and read the advisory.
Weekly insights on software supply chain security, delivered to your inbox.
Your first fix PR is minutes away.
No sales call required, even your agent can complete the purchase over MCP.