CVE-2023-44283 is a high severity (CVSS 7.8) local privilege escalation in Dell SupportAssist. It affects Home PCs versions 3.0 through 3.14.1 and Business PCs versions 3.0 through 3.4.1, and can run code as SYSTEM. Dell fixed it in 3.14.2 for Home and 3.5.0 for Business.
What's affected
Dell advisory DSA-2023-401 lists SupportAssist for Home PCs 3.0 through 3.14.1 and SupportAssist for Business PCs 3.0 through 3.4.1 as affected. The remediated versions are 3.14.2 for Home PCs and 3.5.0 for Business PCs. Dell's only listed mitigation is to update.
Severity agrees. Dell gives a CVSS 3.1 base score of 7.8 (High), and the record shows the same score with vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H. That is a local attack, low complexity, low privileges and no user interaction. The weakness is CWE-284, improper access control. The impact is limited to the single PC, in the Windows SYSTEM context. The record does not mark the CVE as known exploited.
How to check if you're exposed
- On Windows, open Settings, then Apps, and find SupportAssist. Read the version number.
- Home PCs build 3.0 to 3.14.1 and Business PCs build 3.0 to 3.4.1 are in scope.
- In PowerShell,
Get-Package | Where-Object Name -like '*SupportAssist*'lists the installed version. - Use your endpoint management tool to query Dell systems for the product name and version across the fleet.
Safeguard offers a free in-browser dependency scan at gold.safeguard.sh/scan. It reads package manifests, so it will not see installed desktop software or device firmware, but it covers the open source dependencies in your own code.
What to do now
- Update SupportAssist for Home PCs to 3.14.2 or later.
- Update SupportAssist for Business PCs to 3.5.0 or later.
- Let SupportAssist update itself if your policy allows it, and confirm the new version afterwards.
- Uninstall the tool from machines that do not need it.
- Limit standard users' local access on shared machines until patched.
Why it matters
An access control flaw in a service that runs as SYSTEM gives a normal user a path to the machine's highest privilege. Vendor support tools often run with high rights because they need to read hardware and drivers, and that makes them a recurring source of local escalation bugs.
The flaw is local only, so an attacker first needs code running as a normal user. That could come from malware, a phished download or a malicious insider. Privilege escalation then lets that code disable defences, read protected data or install persistence, which is why patching matters even for flaws that are not remote.
Quick check
Which version fixes it on a home PC?
SupportAssist for Home PCs 3.14.2, per Dell.
Which version fixes it on a business PC?
SupportAssist for Business PCs 3.5.0, per Dell.
Sources
Last reviewed: 19 October 2026.