CVE-2023-44281 is a medium severity (CVSS 6.6) elevation of privilege vulnerability in Dell Pair Installer before version 1.2.1. A low privilege local user could delete arbitrary files, causing denial of service. Dell fixed it in version 1.2.1, so update to 1.2.1 or later.
What's affected
Dell advisory DSA-2023-141 lists Dell Pair Installer versions before 1.2.1 as affected and 1.2.1 or later as the remediated version. Updates are available from Dell's Drivers and Downloads site.
Severity agrees. Dell rates it Medium with a CVSS base score of 6.6, and the record shows the same score and vector CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:H. That vector means local access, a low privilege account and user interaction. The weakness is CWE-264, a general permissions and privilege management category. The record does not mark the CVE as known exploited, and the Dell advisory does not say so.
How to check if you're exposed
- On Windows, open Settings, then Apps, and look for Dell Pair or Dell Pair Installer. Read the version.
- In PowerShell,
Get-Package | Where-Object Name -like '*Pair*'lists matching packages and versions. Run it as the user you want to check. - Anything before 1.2.1 is in scope.
- If you manage Dell systems centrally, query your software inventory for the product name.
Safeguard offers a free in-browser dependency scan at gold.safeguard.sh/scan. It reads package manifests, so it will not see installed desktop software or device firmware, but it covers the open source dependencies in your own code.
What to do now
- Update Dell Pair Installer to 1.2.1 or later from Dell's Drivers and Downloads page.
- If you do not need the product, uninstall it.
- Limit local logins on shared or kiosk machines.
- Add the product to your software inventory so versions are tracked.
- Check for other Dell utilities on the same machines and update them as well.
Why it matters
The record says a low privilege user could delete arbitrary files. Installers and updaters often run with high rights, and when they act on paths a normal user can influence, that user may redirect the action. Deleting a protected file can break the system or open another route to escalation.
The score is medium because the attacker needs a local account and user interaction. Even so, local privilege flaws are routinely chained with a first foothold, so a quick update is cheap insurance on any machine with multiple users.
Quick check
Can this be exploited over the network?
No. The vector is local, so the attacker needs an account on the machine.
Which version fixes it?
Dell Pair Installer 1.2.1 or later, per Dell.
Sources
Last reviewed: 19 October 2026.