CVE-2023-45745 is a high severity improper input validation flaw in some Intel TDX module software, scored 7.9. A privileged local user may escalate privileges. Versions before 1.5.05.46.698 are affected, so install the latest update from your system manufacturer. Firmware vendors ship the fix, so check their release notes.
What's affected
Intel's advisory SA-01036 and the NVD record both give the affected range as Intel TDX module software before version 1.5.05.46.698. The fix is that version or later. Intel advises TDX module users to install the latest update from their system manufacturer.
The score is 7.9, High, with the vector CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N. The attacker needs high privileges and local access, and the scope changes, which means the impact reaches beyond the vulnerable component. In a confidential computing setting, that boundary is the point of the feature.
The record also lists a NetApp HCI compute node BIOS as an affected product. NetApp's own advisory is linked from the record, and I did not read it, so check it if you run that hardware.
How to check if you're exposed
The TDX module is firmware level code that supports Intel Trust Domain Extensions, which is used to isolate confidential virtual machines. You will not usually see its version in an operating system package list.
Look at your server vendor's firmware or BIOS release notes for the TDX module version that each release bundles, and compare it with 1.5.05.46.698. Cloud customers should check the provider's statement on the platform. Those who run their own hosts should record the BIOS version per machine.
What to do now
- List hosts that use Intel TDX and their BIOS or firmware versions.
- Read the system manufacturer's release notes for the TDX module version included.
- Install the update that carries 1.5.05.46.698 or later.
- If you rely on confidential VMs from a cloud provider, ask which platform version they run.
- Limit who holds host level privileges on TDX machines.
Why it matters
The weakness is improper input validation, CWE-20. The module accepts input from a privileged software layer and does not check it well enough. In ordinary systems a bug that needs high privileges is a lesser concern. Here the module's job is to keep the host from reading or changing a confidential guest, so a privileged host user is the exact adversary the design is built for.
That is why a 7.9 deserves attention even though it needs local, privileged access. The changed scope in the vector reflects the breach of that boundary.
The CVE is not on the CISA Known Exploited Vulnerabilities list, and the advisory does not report exploitation.
Safeguard's free in-browser dependency scan at gold.safeguard.sh/scan reads the manifests and lockfiles of software projects. It will not see firmware or device images, so for this issue the asset inventory and the vendor advisory are your main tools.
Quick check
Who applies the fix?
The system manufacturer ships it, usually inside a firmware or BIOS update. Intel advises installing the latest update from them.
Is it remotely exploitable?
No. The vector is local and needs a privileged user.
Sources
Last reviewed: 19 October 2026.